Beocenter 9000

20th May 2016

No signs of life were present in this Beocenter with even the red standby light out when power was applied. The supply 5V to the microprocessor section was low at 4.3V with a large amount of ripple present so the voltage at the output of the bridge rectifier 62D7 was checked and found to be around 4.5V instead of the correct 13V. Since there was no overheating apparent 62C17 (10,000uF) was suspected of being open circuit but upon inspection it was discovered that the soldering around this component’s centre pin was cracked. Resoldering this point brought the set back to life with no further attention required. [Beocenter 9000, Beocenter 9500, Beocenter 8000, Beocenter 8500]

Beocenter 2200

20th May 2016

The fault with this set was that FM radio reception was marred by heavy pops, crackles and clicks and was in mono only, AM reception and all other functions being normal. The voltage at 2TP7 (pin 6 of the FM IF amplifier and detector IC 2IC2, LA1235) was low at 0.6V instead of the correct 6.1V, although the voltage at pin 3 of the stereo decoder IC 2IC3 (LA3390) was correct at 4.5V. Disconnecting pin 6 of 2IC2 saw the voltage at the pin of the chip return to normal so leakage in 2C65 and 2C68 was suspected, however the actual cause of the trouble was the trap coil 2L12. The set will function with this coil removed if the input and output connections are shorted together, however in this case a replacement from a scrap set was fitted. This restored correct functioning to the radio section. [Beocenter 2200, Beocenter 2100, Beocenter 4000]

Beovision MX 7000

28th January 2016

The picture on this set was shifted downwards so that the top of the screen was blank and the bottom of the frame invisible. In addition, trapezium distortion was evident, making scrolling credits look like the introduction to a science fiction film! The geometry adjustments in the service menu all had the correct effect but lacked the range to correct the picture. The +10V and -10V supplies to the frame output chip 4IC4 (TDA8172) were correct, as was the 12V supply to the deflection processor. A replacement for 4IC4 was tried but it made no difference. The chassis was tested in another set to confirm that the scan coils were not defective. The real cause was 4R144 (2M7 in some sets, 2M15 in others) which was open circuit, although it measured normally until it was disconnected. This resistor is pert of a bias network which allows the complete vertical deflection circuit to be DC coupled, therefore making possible a shift function in the service menu. [Beovision MX 7000]

Master Control Panel 5000

28th January 2016

If the unit functions erratically or the battery life is short the first thing to check is the voltage across 12R149 (100k). 10 seconds after pressing a key the voltage should be zero, if it isn’t the panel won’t switch off properly. Should a voltage be present, the most likely cause is leakage in the keyboard, this can be localised by checking the voltages across R102 > R118 (10k, even numbers only). Readings other than zero at any of these points show which column the leakage is in. Carefully removing the protective film and the contact plates should allow sufficient access for the area to be cleaned to remove the fault. [Master Control Panel 5000]

Beolit 800

28th January 2016

In this series of sets it is common to find leakage between the track of the bass control and the body, which can affect the operation of the surrounding circuit. Common symptoms are an abrupt change in sound as the control is turned, distortion, lack of volume and intermittent crackling noises. Dismantling and cleaning the control normally effects a cure. The Beolit 700 (note – the old sort!), 611T and 611K use the same type of control and can be affected in the same way. [Beolit 800]

Beovision MX 3500

15th February 2015

This set worked normally except that it couldn’t be switched completely off, pressing stand by only muted the sound and picture, a dull grey glow still being visible on the screen with the tube heaters on and the EHT still present. When first connected to the mains supply the set showed a narrow white line across the screen but gave a normal picture when the <TV> key of the Beolink 1000 was pressed.

With these sets the power supply circuit is switched between normal and stand by operation by the presence or absence of the ‘power fail’ signal at 4P79 and 4P81. This is processed by 4TR35 (BC548B) and voltage checks showed the correct change in voltage was occurring at the emitter of this transistor. 4TR6 (BC548B) also had a changing voltage at its collector, although it was only 9V instead of the correct 19V when stand by was selected. This brought suspicion on 4R87 (680k) and 4D27 (19V zener) but both measured normally. MOSFET transistor 4IC5 (IRF624) was therefore suspect and removing it resulted in the correct voltage change across 4D27. Replacing 4IC5 cleared the fault, slight leakage between the gate and source terminals was suspected although none could be measured. [Beovision MX 3500]

Beovision LX 5500

15th February 2015

If the set shows no sign of life, not even the red stand by indicator, check 10TR8 (BU508AF) which may be short circuit. If this is the case it is worth replacing 10C9 (220uf 16V) as well and checking the surrounding area for corrosion. Permanently joining pins 3 and 5 of 10P30 (the scan coil connector) will also help to prevent future failures of 10TR8. This applies to all the Unity 1 chassis sets, e.g. Beovision MX 3500 and MX 5500, Beovision LX 4500, Beovision LS 4500 and LS 5500. [Beovision LX 5500]

Beovision 601

28th May 2014

This set showed a picture of diminished width which was marred by a single bar of picture distortion which seemed to affect the horizontal scan most greatly. The 180V “B” supply was low at around 155V and even though the “B+ JUST” control 1R100 had an effect on the voltage it could not raise it to the correct level. The 240V “C” supply was also low at around 155V and it was then discovered that there was no voltage across 1C61. 1R98 and 1D5 were suspected but it was 1C61 that proved to be the cause of the trouble, it was open circuit and a replacement restored the correct voltages and resulted in a full sized and undistorted picture. A similar circuit is used in models 600 and 1600 but with different component reference numbers in some cases. [Beovision 600, Beovision 601, Beovision 1600]

Beogram 4000

28th May 2014

Although this turntable appeared to be running at the correct speed the strobe indicator suggested that a large error was present. The fault was due to the indicator mirror being incorrectly positioned so that it was showing the 60Hz rings instead of the 50 Hz ones, for 50 Hz operation the mirror assembly should be moved out to the position furthest from the turntable hub on the adjustable slide. [Beogram 4000]

Beomaster 6000 4channel

23rd May 2014

The fault with this set was that only Tape 4 could be selected, all other modes resulted in an instant return to standby. Even in Tape 4 mode there was no sound, although all the volume and tone control functions operated normally. Assuming that all the supplies are present the voltage across 8R11 (100R) is a good place to start when problems are encountered in this area but it proved to be correct at just under 3V. The muting line should normally be at -5V but was found to be at nearly +10V – this explained the absence of sound. The source of the unwanted positive voltage was 8TR26 but the transistor itself was not faulty; instead 8C12 (47uF 63V) turned out to be leaky and this prevented 8TR26 from turning off fully after the initial reset pulse had been formed. Replacing this capacitor cured all the symptoms. [Beomaster 6000 4channel]